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01 High-resolution optical images:
Microscope images at full resolution

02 Optical image co-registration:
Improved image co-registration workflow

03 T-ReX Feature finding:
Feature finding during manual data import

04 Multiple other feature enhancements:
Various other improvements and changes
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High-resolution optical images:
High-resolution optical images in SCiLS  Lab Stack View

18 November 2024 4

▪ SCiLS Lab supports rendering optical images in 
Stack View at full resolution

▪ Import high-resolution optical images using
▪ SCiLS Lab optical image import 
▪ QuPath-to-SCiLS export plugin
▪ SCiLS Exchange Format (SEF) files 
▪ SCiLS API

▪ Whole-slide brightfield imaging data in file formats 
supported by the OpenSlide library are compatible
▪ NOTE: whole-slide fluorescence data is not supported

Innovation with Integrity

Data formats supported by the OpenSlide library

Data format / vendor Extensions Data format / vendor Extensions

Aperio .svs, .tif Philips .tiff

DICOM .dcm Sakura .svslide

Hamamatsu .vms, .vmu, .ndpi Trestle .tif

Leica .scn Ventana .bif, .tif

MIRAX .mrxs Generic tiled TIFF .tif
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High-resolution optical images:
Optical image storage in SCiLS  Lab
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▪ Optical image handling has fundamentally changed 
in SCiLS Lab 2024b

▪ Previously, optical images were
▪ Stored in the .slx file
▪ Maximum file size of 1 GB
▪ Down-sampled to max. 8000×8000 pixels
▪ Rendered as down-sampled image in Stack View

▪ Now, data sets can contain
▪ Legacy images
▪ Internal images
▪ External images

Innovation with Integrity
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High-resolution optical images:
Optical image storage in SCiLS  Lab

18 November 2024 6

▪ Optical image handling has fundamentally changed 
in SCiLS Lab 2024b

▪ Previously, optical images were
▪ Stored in the .slx file
▪ Maximum file size of 1 GB
▪ Down-sampled to max. 8000×8000 pixels
▪ Rendered as down-sampled image in Stack View

▪ Now, data sets can contain
▪ Legacy images
▪ Internal images
▪ External images

▪ Objects tab displays optical image information
▪ Internal/Legacy or matching image found at path: 
▪ Path inaccessible or non-matching image found:

Innovation with Integrity
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High-resolution optical images:
Optical image storage in SCiLS  Lab
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▪ To facilitate high-resolution rendering for large 
“flat” images, these images are converted to a 
pyramidal format and treated as External images

Innovation with Integrity
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High-resolution optical images:
Optical image storage in SCiLS  Lab

18 November 2024 8

▪ To facilitate high-resolution rendering for large 
“flat” images, these images are converted to a 
pyramidal format and treated as External images

▪ Allows importing pre-processed fluorescence 
microscopy images into SCiLS Lab

Innovation with Integrity
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High-resolution optical images:
Updating external image locations in the Objects tab

18 November 2024 9

▪ In case external image files are re-located the 
external file references will need updating
▪ Warning upon opening SCiLS Lab data set
▪ High-resolution rendering unavailable for affected 

external images, placeholder image is shown

▪ Objects tab displays optical image information
▪ Internal/Legacy or matching image found at path: 
▪ Path inaccessible or non-matching image found:

▪ The “Edit” properties dialog can be used to:
▪ Update path to external image
▪ Remove the external file reference

▪ External image files unaffected
▪ Placeholder image unaffected
▪ Cannot be undone

Innovation with Integrity
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▪ The QuPath-to-SCiLS export plugin facilitates the 
transport of region annotations between SCiLS Lab 
and QuPath

▪ Plugin v1.4 transports external optical image 
references between SCiLS Lab and QuPath

▪ SCiLS Lab and QuPath access the same external 
optical image to avoid data duplication

▪ A reference to an external optical image can be 
added to the updated SCiLS Exchange Format 

LIFE SCIENCES MASS SPECTROMETRY

High-resolution optical images:
Improved integration between SCiLS  Lab and QuPath

18 November 2024 10Innovation with Integrity
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High-resolution optical images::
SCiLS  Lab performance high-resolution optical image rendering

18 November 2024 11

▪ Whole-slide imaging data is read from disk and is 
not fully loaded into memory. When navigating 
through an image, the image tiles that were 
“visited” are temporarily stored, or cached, in 
memory to revisit them more efficiently later

▪ To enhance the user experience and improve the 
performance of viewing high resolution optical 
images in SCiLS Lab, the Tile Cache Size can be 
increased on the Advanced tab of File>SCiLS Lab 
Settings

Innovation with Integrity
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Optical image co-registration:
Improved image co-registration workflow

18 November 2024 13Innovation with Integrity

▪ To accommodate working with high-resolution 
optical images, SCiLS Lab has a new two-step
and interactive image co-registration module

▪ Access the new image registration module via 
File > Import > Optical Image (Co-Register new 
image)

▪ Select the image you want to co-register to the 
MALDI Imaging data, this is the Moving image

▪ In the registration wizard, select the Reference 
image, which is already present in the data set

▪ Use the Image Orientation step to match the 
orientation of the moving image to the reference 
image
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Optical image co-registration:
Improved image co-registration workflow

18 November 2024 14Innovation with Integrity

▪ Following Image Orientation, continue to the Image 
Co-registration, which is based on anchors to 
adjust the moving image
▪ 1 anchor – adjust position
▪ 2 anchors – adjust rotation and scaling
▪ 3 anchors – compensate for shearing artefacts

▪ The detailed registration is interactive and 
immediately displays the result of the input actions

▪ Anchor operations
▪ Create by clicking in the registration window
▪ Move to adjust the moving image position
▪ Relocate (click on the teachbox border and drag)
▪ Delete to undo image transformation
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Optical image co-registration:
Improved image co-registration workflow

18 November 2024 15Innovation with Integrity

▪ Display Stack View content in the registration 
window to allow direct registration to ion images, 
component analysis results, regions, labels, 
external images, or any combination of these
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T-ReX® Feature Finding:
Feature Finding upon manual import of data

18 November 2024 17

▪ During the manual import of timsTOF fleX and/or 
centroided MRMS data into SCiLS Lab, T-ReX
Feature Finding can be enabled to run during the 
import procedure
▪ T-ReX2 for MRMS and QTOF data
▪ T-ReX3 for TIMS data

▪ For CCS-enabled timsTOF fleX data, the CCS 
extraction can also be enabled to run during data 
import

▪ Parameters and results are identical to operating 
the Feature Finding tool in SCiLS Lab

Innovation with Integrity
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Multiple feature 
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Multiple feature enhancements:
Changed mouse & keyboard interactions in Stack View

18 November 2024 19

▪ The mouse and keyboard interactions to navigate
in Stack View have been updated

Innovation with Integrity
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Multiple feature enhancements:
Improvements of the Objects tab functionality

18 November 2024 20

▪ Display of data sources has been moved from File 
Properties to Objects tab

▪ Accessibility of source data is shown in Objects tab
▪ Accessible: 
▪ Inaccessible:

▪ Update path to the source data set via the “Edit” 
properties

▪ For timsTOF fleX data, a change in the active 
calibration of the source data is shown: 

▪ The calibration file active at the time of importing 
the source data into SCiLS Lab can be exported

Innovation with Integrity
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Multiple feature enhancements:
Improved single spectrum viewing

18 November 2024 21

▪ Displaying single spectra has been improved to 
work like displaying ion images

▪ Select a single spectrum with a single click

▪ Add single spectra to the Spectra list by using 
Alt + click

Innovation with Integrity



|| ||© 2024 Bruker     For Research Use Only. Not for use in clinical diagnostic procedures.

LIFE SCIENCES MASS SPECTROMETRY

Multiple feature enhancements:
Spectrum plotter differentiates m/z and CCS features

18 November 2024 22

▪ m/z and CCS features have different icons in the 
Spectrum panel
▪ m/z feature 
▪ CCS feature 

▪ Colors differentiate features in the ion image list 
from features in the active feature list

Innovation with Integrity
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Multiple feature enhancements:
Optimize SCiLS Lab file size

18 November 2024 23

▪ Over time, the .slx file of a SCiLS Lab data set can 
accumulate redundant information, putting a 
burden on storage space
▪ For example, unused extracted CCS images

▪ File > Optimize file size will clean up the SCiLS Lab 
data set and remove redundant information, saving 
disk space

Data set 1 Data set 2

Number of pixels 66925 66925

.slx size after import 319 MB 94 MB

# CCS features after import 873 0

# CCS features after feature filtering 10 10

.slx size after feature filtering 319 MB 100 MB

.slx size after “optimize file size” 98 MB 100 MB

Innovation with Integrity
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Multiple feature enhancements:
Improved Stack View readability

18 November 2024 24

▪ To enhance the readability of the ion information, 
scale bar, color bar and error messages in Stack 
View, a thin text outline has been introduced

▪ The color and outline are dependent on the 
Background Color setting that can be adjusted via 
File > SCiLS Lab settings 

Innovation with Integrity

Background Color: White

Background Color: Black/Gradient
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Multiple feature enhancements:
Prevent loading data from unsafe file systems

18 November 2024 25

▪ After several customer cases involving irreparable 
.slx file corruption on external drives, the use of 
certain file systems (incl. exFAT) has been deemed 
unsafe

▪ Opening SCiLS Lab files from unsafe file systems, 
or storing new SCiLS Lab files on unsafe file 
systems using the Importer is therefore disabled 
by default

▪ Through File > Settings users can enable reading 
and writing to unsafe file systems, at the risk of 
causing irreparable damage to their data

Innovation with Integrity



|| ||© 2024 Bruker     For Research Use Only. Not for use in clinical diagnostic procedures.

LIFE SCIENCES MASS SPECTROMETRY

Multiple feature enhancements:
Prevent loading data from unsafe file systems using the API

18 November 2024 26

▪ Similar to SCiLS Lab, the SCiLS API, by default, 
can no longer access files that are stored on 
unsafe file systems.

▪ Although not recommended, users can override 
this restriction when creating a new API session.
▪ R client: 

▪ SCiLSLabOpenLocalSession() 
▪ Set “overrideFilesystemCheck” to TRUE

▪ Python client: 
▪ LocalSession() 

▪ Set “override_filesystem_check” to TRUE

Innovation with Integrity
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Multiple feature enhancements:
Prevent loading data from unsafe file systems

18 November 2024 27

▪ To check the current file system of a storage 
device, This computer > right-click drive > 
Properties

▪ To change an unsafe file system, select “Format…” 
and choose a file system considered safe 
▪ For example, NTFS
▪ NOTE: Formatting a drive erases all its content. 

Create a backup before taking this action!

Innovation with Integrity
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Multiple feature enhancements:
Multi-modal imaging integration using the SCiLS API

18 November 2024 29

▪ The introduction of External Features in SCiLS 
2024a creates new possibilities for the analysis of 
multi-modal imaging data in SCiLS Lab

▪ From SCiLS 2024b onwards, the SCiLS API can 
write External Features into a data set, which 
allows users to write any image into a data set

▪ For joint analysis, images should be co-registered 
and re-sampled to the SCiLS Lab coordinate 
system

▪ Example scripts for R and Python, as well as 
detailed explanations on re-sampling strategies are 
provided in the SCiLS API documentation

Innovation with Integrity
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Open changelog in SCiLS Lab:

▪ Help > What‘s New, or

▪ Ctrl + B
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SCiLS  Lab 2024b Changelog

18 November 2024 30Innovation with Integrity
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